Édition, impression, rédaction

SPIPDF

Générer des contenus sur mesure en PDF

Préfixe : spipdf
Utilisé dans 870 sites
Mis à jour le 8 mai 2017
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

1.0.6 - en test

Compatible : SPIP 3.1 SPIP 3.0
Afficher la description

Ce plugin permet de convertir un article au format PDF par le biais d’un simple squelette codé en HTML 4.01. Il utilise la librairie HTML2PDF ou la librairie mPDF. Il nécessite PHP 5

Version
1.0.6
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.1.*
État
en test
Auteur
Yves Tannier
Licence
LGPL
Module de langue
spipdf
Langue référence
français
Gestionnaire
salvatore
Traductions
français
Archive
spipdf.zip
Taille
16.1 ko
Générée le
08-05-2017 12:04
Hébergée par
SPIP-Zone - Plugins

0.2.14 - stable

Compatible : SPIP 3.0 SPIP 2.1 SPIP 2.0
Afficher la description

Ce plugin permet de convertir un article au format PDF par le biais d’un simple squelette codé en HTML 4.01. Il utilise la librairie HTML2PDF ou la librairie mPDF. Il nécessite PHP 5.

Version
0.2.14
Compatiblité
SPIP ≥ 2.0.0 et ≤ 3.0.*
État
stable
Auteur
Yves Tannier, grafactory.net
Licence
GPL 3
Copyright
2010-2015
Archive
spipdf_v0.zip
Taille
14.7 ko
Générée le
08-05-2017 12:04
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

  • Revision 104338  : zone.spip est maintenant en https, donc j’ajoute le "s"
  • Revision 104336  : Ce n’est plus ​http://trad.spip.org mais ​https://trad.spip.net trad.spip est en https (...)
  • Revision 103864  : En finir une fois pour toutes avec spip-contrib, pour mettre à la place contrib.spip
  • Revision 103720  : Contrib est en https, donc j’ajoute le "s", plus divers broutilles
  • Revision 103279  : corrections pour le nom du fichier pdf sortant et pour l’évaluation du paramètre de langue dans (...)
  • Revision 103151  : eviter d’avoir des caracteres exotiques dans les noms des fichiers
  • Revision 101517  : correction image centrée, d’après ​https://contrib.spip.net/spiPDF-generer-des-contenus-sur-mesure-en-PD
  • Revision 93816  : Coding rules (indentation, guillemets etc)
  • Revision 93332  : Compatiblité SPIP 3.1©
  • Revision 88514  : Report de r88513 spipdf_nettoyer_html() : utilisation expressions rationnelles un peu plus (...)

Messages de forum

  • 20 mai : Bonjour :-) Normalement, vous devriez pouvoir le faire, par contre, il faut être minimum en (...)
  • 20 mai : J’ai envoyé une infolettre par l’intermédiaire de Mailjet en renseignant soigneusement les codes (...)
  • 20 mai : le lien correct vers la source est : https://raw.githubusercontent.com/abelass/spip_gis_communes_bel
  • 20 mai : Salut b_b, Je suis en train d’écrire un plugin qui importe les communes belges comme point gis. (...)
  • 20 mai : Mince, pas possible d’activer ce chouette plugin sur un site en 3.1. Il n’est pas compatible 3.1 (...)
  • 20 mai : Merci Olivier, En effet, en inversant right et left à la ligne 16 on obtient : $dir = (...)
  • 19 mai : en voulant envoyer une infolettre à 1 destinataire, j’ai le message : Oups. Une erreur (...)
  • 19 mai : Pour finir, j’ai corrigé le soucis temporairement en parametrant le SMTP de MailJET dans MailSHOT (...)
  • 19 mai : Petite rectification, on utilise pas l’API car facteur ne prends en charge que la config via (...)
  • 19 mai : Donc commencer par regarder les sites de l’hebergeur/de mailjet pour voir si changement. (...)