Outil de développement

INCARNER

Changer rapidement d’utilisateur durant le développement.

Préfixe : incarner
Mis à jour le 13 octobre 2017
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

1.3.1 - en test

Compatible : SPIP 3.2 SPIP 3.1 SPIP 3.0
Afficher la description

Permet aux webmestres de changer d’utilisateur très facilement. Très pratique pour débugger des autorisations.

Ce plugin ajoute un lien « se connecter en tant que XX » sur chaque page auteur dans l’espace privé, ainsi qu’un lien « redevenir XX » côté public, qui permet de redevenir le webmestre qu’on était à la base. On peux aussi changer d’utilisateur en visitant l’url spip.php ?action=incarner&login=toto

Ce plugin est un trou de sécurité, NE PAS ACTIVER EN PRODUCTION !

Version
1.3.1
Compatiblité
SPIP ≥ 3.0.11 et ≤ 3.2.*
État
en test
Auteur
Michel Bystranowski
Licence
GNU/GPL
Module de langue
incarner
Langue référence
français
Traductions
français
Archive
incarner.zip
Taille
36.2 ko
Générée le
13-10-2017 17:04
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

Messages de forum

  • 9 octobre : J’ai vu que tu l’avais fait, c’est parfait
  • 9 octobre : Bonne idée, je vais ajouter les boutons côté privé dans la prochaine version (...)
  • 9 octobre : Pas à 100%, sans donner lecture à /dev/urandom, je tombais sur le dernier cas ici : (...)
  • 9 octobre : Bizarre, le plugin utilise pourtant un polyfill de la fonction random_bytes qui devrait définir (...)
  • 9 octobre : Petite remarque, j’en ai besoin principalement dans le privé et il n’est pas fait mention que l’on (...)
  • 9 octobre : Plugin fort utile. Une fonctionnalité que l’on retrouve de plus en plus dans les logiciels et (...)
  • 19 septembre : C’est bien le fonctionnement prévu. Après une première déconnexion, on « incarne » un utilisateur (...)
  • 18 septembre : La version mise à jour fonctionne sur mon site. Cela va me faire gagner du temps dans la gestion (...)
  • 18 septembre : Oups. Viens de voir qu’il y avait une mise à jour dispo dans la partie « gestion des plugins ». Je (...)
  • 18 septembre : Merci d’avoir répondu aussi rapidement. En effet mon hébergeur est sous Php 5.2.17. Où puis je (...)