Administration du site

Import-Export

Importer, exporter des configurations de plugins

Préfixe : ieconfig
Utilisé dans 131 sites
Mis à jour le 14 juillet 2021
SPIP 4.0

2.0.12  en développement

Télécharger

Mis à jour le 14 juillet 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

Ce plugin permet d’exporter la configuration de SPIP et des plugins compatibles dans un seul et unique fichier au format YAML. Ces fichiers de configuration peuvent ensuite être importés.

Fichier XML
Version
2.0.12
Compatiblité
SPIP ≥ 3.0.0 et ≤ 4.0.*
État
en développement
Auteur
Joseph
Licence
GPL 3
Module de langue
ieconfig
Langue référence
français
Gestionnaire
salvatore
Traductions
English (Benitron) , français , slovenčina (jaro)
Archive
ieconfig-eeb6f-v2.0.12.zip
Taille
37 ko
Générée le
14-07-2021 09:57
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 3.23.2
API de vérification ≥ 1.0.0
YAML ≥ 1.5.3

1.3.3  stable

Télécharger

Mis à jour le 22 mars 2021

Compatible :
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

Ce plugin permet d’exporter la configuration de SPIP et des plugins compatibles dans un seul et unique fichier au format YAML. Ces fichiers de configuration peuvent ensuite être importés.

Fichier XML
Version
1.3.3
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.2.*
État
stable
Auteur
Joseph
Licence
GPL 3
Archive
ieconfig-eeb6f-v1.3.3.zip
Taille
37.2 ko
Générée le
22-03-2021 22:25
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 3.50.2
API de vérification ≥ 1.0.0
YAML ≥ 1.5.3

0.2.7  stable déprécié

Télécharger

Mis à jour le 24 décembre 2018

Compatible :
  • SPIP 2.1

Ce plugin permet d’exporter la configuration de SPIP et des plugins compatibles dans un seul et unique fichier au format YAML. Ces fichiers de configuration peuvent ensuite être importés.

Fichier XML
Version
0.2.7
Compatiblité
SPIP ≥ 2.1.0 et ≤ 2.1.99
État
stable
Auteur
Joseph
Licence
GPL 3
Archive
ieconfig-eeb6f-v0.2.7.zip
Taille
75.1 ko
Générée le
24-12-2018 14:19
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
SPIP Bonux ≥ 1.8.10
Saisies pour formulaires ≥ 1.42.11
API de vérification
YAML ≥ 1.5.2

Dernières modifications

  • b2df138 : Compatible SPIP 4.0
  • 705d6ba : Saises : datas → data
  • e64b331 : Compatibilité SPIP 3.3 : fixer la taille des icones (parce qu'en SVG, certaines sont immenses (...)
  • 31ac175 : [Salvatore] [source:lang/ paquet-ieconfig] Export depuis https://trad.spip.net de la langue fr (...)
  • c28b0f7 : [Salvatore] [source:lang/ ieconfig] Export depuis https://trad.spip.net de la langue fr (...)
  • 48e826f : [Salvatore] [source: paquet-ieconfig] Export depuis https://trad.spip.net de la langue fr (...)
  • 1b827e4 : [Salvatore] [source: ieconfig] Export depuis https://trad.spip.net de la langue fr [Salvatore] (...)
  • 5f29f2f : être certain que les plug ont une version de saisies "sûr", normalement, cela devrait être bon, (...)
  • d8285af : Eviter une notice PHP. Je ne comprends pas d'ailleurs comment elle a pu nous échapper depuis (...)
  • 3bb06f4 : [Salvatore] [source:_plugins_/ieconfig/trunk/lang/ ieconfig] Export depuis (...)

Tickets ouverts

  • Ticket 3 : Sauver préfixe et version des plugins
  • Ticket 2 : Déclarer stable
  • Ticket 1 : Ajouter des commandes SPIP-Cli pour exporter et importer

Messages de forum

  • 13 juin 2018 : Hello Joseph, Je pense que c’est effectivement la meilleur solution ;-) on va partir sur (...)
  • 12 juin 2018 : Salut Mist. GraphX, tout d’abord, je suis plus que ravi de voir que ce plugin continue de vivre (...)
  • 12 juin 2018 : Donc suite a notre discussion, j’ai envoyé les surcharges permettant de gérer ces exports (...)
  • 12 juin 2018 : Comme sur d’autres plugin ou objets ça a été refusé et je l’ai intégré au core de mon (...)
  • 11 juin 2018 : Et ça a donné quoi ?
  • 7 janvier 2015 : Oui tu as raison je vais le proposer sur le forum de formidable et l’auteur verra si ça a un (...)
  • 4 janvier 2015 : Un grand merci pour cette contribution. As-tu pensé à la proposer sur SPIP-Zone ? Elle aurait (...)
  • 4 janvier 2015 : Bonjour, Il y’a quelques mois j’avais posé la question de l’export des formulaires ... donc c’est (...)
  • 10 octobre 2014 : Merci beaucoup pour la réponse. En effet le paramètre xdebug.max_nesting_level est bien (...)
  • 9 octobre 2014 : Ce message d’erreur est en général dû à la présence sur votre hébergement PHP de xdebug (et non à PHP (...)