Outil de développement

HTML5

Améliorer l’usage de HTML5 dans SPIP

Préfixe : html5
Utilisé dans 10 sites
Mis à jour le 8 mai 2019
  • SPIP 2.0
  • SPIP 2.1
  • SPIP 3.0
  • SPIP 3.1
  • SPIP 3.2

1.0.2 - en test

Compatible : SPIP 2.0 SPIP 2.1 SPIP 3.0 SPIP 3.1 SPIP 3.2
Afficher la description

Ce plugin améliore l’usage de HTML5 dans votre site SPIP en ajoutant :

  • un script pour émuler les balises HTML5 dans les vieux navigateurs,
  • surcharge de certains formulaires SPIP,
  • correction des erreurs résiduelles dans le code généré,
  • sans oublier d’activer HTML5 dans SPIP.
Version
1.0.2
Compatiblité
SPIP ≥ 2.0.0 et ≤ 3.2.*
État
en test
Auteur
davux, tetue
Licence
GPL 3, WTFPL
Archive
html5.zip
Taille
17.7 ko
Générée le
09-08-2019 10:44
Hébergée par
SPIP-Zone - Externals

0.2.1 - en développement

Compatible : SPIP 2.0 SPIP 2.1
Afficher la description

Ce plugin pose les bases pour faire un site en HTML5. Il fournit actuellement :

  • un sol commun pratique : reset CSS et un petit fichier javascript pour faire "voir" les balises à Internet Explorer
  • une surcharge de certains formulaires de SPIP pour utiliser les nouveaux types d’<input>
Version
0.2.1
Compatiblité
SPIP ≥ 2.0.0 et ≤ 2.1.*
État
en développement
Auteur
davux
Licence
GPL 3
Archive
html5-2014.zip
Taille
19 ko
Générée le
09-08-2019 10:44
Hébergée par
SPIP-Zone - Externals

Dernières modifications

Information non disponible

Messages de forum

  • 10 juillet : idem j’ai un /n qui se ballade sur le sommaire de tous les sites de la mutualisation
  • 10 juillet : idem j’ai un /n qui se ballade sur le sommaire de tous les sites de la mutualisation
  • 17 juin : Bonjour, Ce plugin ajoute cette ligne dans le head < !--[if lt IE 9]>\n< script (...)
Plugins SPIP
Ce site sous SPIP 3.2.4 SVN [24325] utilise les plugins :