Outil de développement

JQUERY UI

Animations, effets et widgets jQuery

Préfixe : jqueryui
Utilisé dans 28042 sites
Mis à jour le 2 avril 2017
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

1.11.4 - stable

Compatible : SPIP 3.1
Afficher la description

Ce plugin implémente dans SPIP la bibliothèque complémentaire jQuery UI autorisant la création de composants graphiques dynamiques : onglets, drag & drop, barres de progression... Les fonctionnalités de cette bibliothèque se divisent en 3 catégories :

  • Les interactions. Elles permettent de donner des propriétés très intéressantes à des éléments HTML, comme le fait de pouvoir être attrapés et déplacés avec la souris (drag & drop), d’être redimensionnés comme une fenêtre, ou encore d’être sélectionnés comme des icones sur le bureau de votre OS.
  • Les Widgets. Ce sont des objets « clé en main » qui proposent des fonctionnalités de haut niveau comme le DatePicker par exemple, qui affiche un calendrier permettant de sélectionner une date.
  • Les effects. Ils enrichissement les effets par défaut proposés par jQuery (fadeIn, slideUp...). Grâce à jQuery UI, il est par exemple possible d’animer la propriété CSS background-color avec .animate() ou encore d’ajouter des transitions lors des addClass/removeClass...
Version
1.11.4
Compatiblité
3.1.0 ≤ SPIP ≤ 3.1.*
État
stable
Auteur
Collectif SPIP
Crédits
jQuery UI Team
Archive
jquery_ui.zip
Taille
283.3 ko
Générée le
28-06-2016 14:04
Hébergée par
SPIP-Zone - Core

1.8.21 - stable

Compatible : SPIP 3.0
Afficher la description

Ce plugin implémente dans SPIP la bibliothèque complémentaire jQuery UI autorisant la création de composants graphiques dynamiques : onglets, drag & drop, barres de progression... Les fonctionnalités de cette bibliothèque se divisent en 3 catégories :

  • Les interactions. Elles permettent de donner des propriétés très intéressantes à des éléments HTML, comme le fait de pouvoir être attrapés et déplacés avec la souris (drag & drop), d’être redimensionnés comme une fenêtre, ou encore d’être sélectionnés comme des icônes sur le bureau de votre OS.
  • Les Widgets. Ce sont des objets « clé en main » qui proposent des fonctionnalités de haut niveau comme le DatePicker par exemple, qui affiche un calendrier permettant de sélectionner une date.
  • Les effects. Ils enrichissement les effets par défaut proposés par jQuery (fadeIn, slideUp...). Grâce à jQuery UI, il est par exemple possible d’animer la propriété CSS background-color avec .animate() ou encore d’ajouter des transitions lors des addClass/removeClass...
Version
1.8.21
Compatiblité
3.0.0 ≤ SPIP ≤ 3.0.*
État
stable
Auteur
Collectif SPIP
Crédits
jQuery UI Team
Archive
jquery_ui_30.zip
Taille
326.5 ko
Générée le
23-12-2015 14:09
Hébergée par
SPIP-Zone - Core

1.8.19 - stable

Compatible : SPIP 2.1 SPIP 2.0
Afficher la description

De plus en plus de plugins intègrent dans leurs fichiers des morceaux de la bibliothèque jQuery UI et ce dans des versions plus ou moins à jour imposant ainsi de temps à autre plusieurs versions de cette bibliothèque en fonction du nombre de plugins installés sur un site.

Ce méta plugin s’occupe de gérer correctement l’insertion de la bibliothèque jQuery UI dans les squelettes, suivant la demande des plugins clients.

A noter que la bibliothèque jQuery UI est intégrée dans le core de Spip 3

Version
1.8.19
Compatiblité
2.0.0 ≤ SPIP ≤ 2.1.*
État
stable
Auteur
jQuery Team
Module de langue
jqueryui
Langue référence
français
Gestionnaire
salvatore
Traductions
English (Davood Hossein, kent1) , Español (severo) , فارسى (Davood Hossein) , français , Nederlands (Hanjo) , òc nissart (mistralenc) (sylvain) , slovenčina (jaro)
Archive
jquery_ui_spip2.zip
Taille
350.8 ko
Générée le
02-04-2017 18:04
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires
Nécessite les librairies
Pour 2.0.0 ≤ SPIP ≤ 2.0.* :
jquery.ui-1.6
Compatible avec
Pour 2.1.0 ≤ SPIP ≤ 2.1.* :
SPIP Bonux

Dernières modifications

  • Revision 98589  : report de r98588 / retour sur r83728 : fixer le gestion du renommage des scripts effect (...)
  • Revision 94479  : SPIP 3.1 branchons !
  • Revision 94477  : Les plugins dist de spip 3.1 ne sont que pour spip 3.1, donc, changement de (...)