Développement de sites et de plugins

YAML

Un format de fichier simple pour éditer des listes de données

Préfixe : yaml
Utilisé dans 1652 sites
Mis à jour le 12 août 2021
SPIP 4.0

3.0.0  stable

Télécharger

Mis à jour le 9 juillet 2021

Compatible :
  • SPIP 4.0

Ce plugin fournit les fonctions de lecture/écriture du format YAML : yaml_decode() et yaml_encode(). Il fournit aussi le format yaml pour la boucle (DATA).

Fichier XML
Version
3.0.0
Compatiblité
SPIP ≥ 4.0.0 et ≤ 4.0.*
État
stable
Auteur
Fil, Eric Lupinacci
Crédits
yaml.org, Spyc, Symfony YAML v1 - Fabien Potencier, Symfony YAML v4 - Fabien Potencier, PECL YAML - The PHP Group, LibYAML
Licence
MIT
Archive
yaml-e320e-v3.0.0.zip
Taille
194 ko
Générée le
09-07-2021 16:48
Hébergée par
SPIP-Zone - Plugins

2.0.18  stable

Télécharger

Mis à jour le 12 août 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

Ce plugin fournit les fonctions de lecture/écriture du format YAML : yaml_decode() et yaml_encode(). Il fournit aussi le format yaml pour la boucle (DATA).

Fichier XML
Version
2.0.18
Compatiblité
SPIP ≥ 3.0.0 et ≤ 4.0.*
État
stable
Auteur
Fil, Eric Lupinacci
Crédits
yaml.org, Spyc, Symfony YAML v1 - Fabien Potencier, Symfony YAML v4 - Fabien Potencier, PECL YAML - The PHP Group, LibYAML
Licence
MIT
Archive
yaml-e320e-v2.0.18.zip
Taille
194.4 ko
Générée le
12-08-2021 22:53
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Pour SPIP ≥ 3.1.0 :
php ≥ 5.3.0

1.5.4  stable

Télécharger

Mis à jour le 29 mai 2018

Compatible :
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Ce plugin fournit les fonctions de lecture/écriture du format YAML : yaml_decode() et yaml_encode(). Il fournit aussi le format yaml pour la boucle (DATA).

Fichier XML
Version
1.5.4
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.2.*
État
stable
Crédits
yaml.org, Spyc, Symfony YAML - Fabien Potencier
Licence
MIT
Archive
yaml-e320e-v1.5.4.zip
Taille
47.4 ko
Générée le
29-05-2018 19:31
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

  • 6f5a1a1 : Version 3.0.0 uniquement pour SPIP 4.0+ ; Il y aura des nettoyages à faire, mais on pourra (...)
  • d913054 : Suppression du fichier .gitattributes inutile.
  • 3d32ca0 : compat SPIP 4
  • 19a1523 : [ui] logo SVG
  • a229aa3 : Saisies: datas->data, sauf pour les demos qui sont visiblement des formulaires (...)
  • 389081a : que ce soit en lecture ou en écriture, je n'ai remarqué aucun pb en 3.3
  • d64a5e7 : passage en stable (dixit Eric)
  • 7177ce5 : [Salvatore] [source:lang/ paquet-yaml] Export depuis https://trad.spip.net de la langue fr (...)
  • 2c7308b : [Salvatore] [source: paquet-yaml] Export depuis https://trad.spip.net de la langue fr (...)
  • 5575c0d : Ajout des auteurs du plugin.

Messages de forum

  • 24 août : bonjour , j’ai passé mon site en spip 4 et ai remis YAml (donc V3.00) et en partie privée , il (...)
  • 30 juillet : Pour info Eric tu avais créé le tag sans mettre à jour le paquet, puis marcimat était intervenu (...)
  • 30 juillet : Merci JLuc Alors pour le PHP, je suis chez free.. Mais je viens de me rendre compte que c’est (...)
  • 30 juillet : La version 2.0.14 est adaptée à spip 3.2 cf https://plugins.spip.net/yaml.html?compatible_spip=3.2
  • 29 juillet : Bonjour, J’ai un site en php 5.6.34 et spip 3.2 J’ai un problème avec la version 2.0.14 qui est (...)
  • 11 mai : Exact et c’est complètement incompréhensible. Je vais créer un tag 2.0.15 de suite avec la bonne (...)
  • 11 mai : J’ai cru devenir fou en allant voir git... car la borne est bien en 3.0 Mais en fait c’est (...)
  • 11 mai : Bonjour, Non cela n’a pas été fait. La version n’a pas changé d’intervalle de compatibilité. (...)
  • 11 mai : Bonjour, J’ai encore un site en php 5.3.3 donc spip 3.1 J’ai un problème avec la version 2.0.14 (...)
  • 28 février 2019 : Merci pour le conseil et la très pratique page de test. Cela m’a permit de mettre le main sur le (...)