Développement de sites et de plugins

API de vérification

Une API générique pour vérifier une valeur

Préfixe : verifier
Utilisé dans 1943 sites
Mis à jour le 9 mai 2022
SPIP 4.1

3.0.0  stable

Télécharger

Mis à jour le 9 mai 2022

Compatible :
  • SPIP 4.1
  • SPIP 4.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
3.0.0
Compatiblité
SPIP ≥ 4.0.0 et ≤ 4.1.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Module de langue
verifier
Langue référence
français
Gestionnaire
salvatore
Traductions
català , Deutsch (klaus++, Torsten Willmann) , English (Benitron, George, Hanjo, jack31, kent1, Mark, RastaPopoulos, tcharlss) , Español (Raquel S. Bujaldón, tcharlss) , فارسى (Davood Hossein) , français , français copain (beatnick, Cerf, maieul, RealET, stefdn) , italiano (Cap) , Nederlands (Hanjo) , Português (Miguel) , Português do Brasil (Ricardo Porto) , русский (nazar) , slovenčina (jaro)
Archive
verifier-0673c-v3.0.0.zip
Taille
176.1 ko
Générée le
09-05-2022 21:35
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

2.1.2  stable

Télécharger

Mis à jour le 18 avril 2022

Compatible :
  • SPIP 4.1
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
2.1.2
Compatiblité
SPIP ≥ 3.2.0 et ≤ 4.1.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v2.1.2.zip
Taille
179.3 ko
Générée le
18-04-2022 10:14
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

2.0.0  stable

Télécharger

Mis à jour le 19 juillet 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
2.0.0
Compatiblité
SPIP ≥ 3.2.0 et ≤ 4.0.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v2.0.0.zip
Taille
173 ko
Générée le
19-07-2021 12:14
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.17.1  stable

Télécharger

Mis à jour le 19 juillet 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.17.1
Compatiblité
SPIP ≥ 3.0.0 et ≤ 4.0.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.17.1.zip
Taille
175.8 ko
Générée le
19-07-2021 11:49
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.16.4  stable

Télécharger

Mis à jour le 10 juin 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.16.4
Compatiblité
SPIP ≥ 3.0.0 et ≤ 4.0.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.16.4.zip
Taille
112.8 ko
Générée le
10-06-2021 17:42
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.15.0  stable

Télécharger

Mis à jour le 11 avril 2021

Compatible :
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.15.0
Compatiblité
SPIP ≥ 3.1.0 et ≤ 3.3.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.15.0.zip
Taille
112 ko
Générée le
11-04-2021 23:22
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.14.0  stable

Télécharger

Mis à jour le 25 mars 2021

Compatible :
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.14.0
Compatiblité
SPIP ≥ 3.1.0 et ≤ 3.3.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.14.0.zip
Taille
110.3 ko
Générée le
25-03-2021 19:22
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.13.1  stable

Télécharger

Mis à jour le 8 mars 2021

Compatible :
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.13.1
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.3.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.13.1.zip
Taille
110.4 ko
Générée le
08-03-2021 10:07
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.12.0  stable

Télécharger

Mis à jour le 28 février 2021

Compatible :
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.12.0
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.3.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.12.0.zip
Taille
110.3 ko
Générée le
28-02-2021 10:57
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.11.1  stable

Télécharger

Mis à jour le 22 juillet 2020

Compatible :
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.11.1
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.3.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.11.1.zip
Taille
107.5 ko
Générée le
22-07-2020 13:19
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.10.0  stable

Télécharger

Mis à jour le 27 mai 2020

Compatible :
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.10.0
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.2.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.10.0.zip
Taille
104.6 ko
Générée le
27-05-2020 11:08
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

1.9.7  stable

Télécharger

Mis à jour le 10 mai 2020

Compatible :
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0
  • SPIP 2.1
  • SPIP 2.0

Fournit une fonction unique verifier($valeur, $type, $options, &$valeur_normalisee) permettant de tester la validité d’une valeur.

Fichier XML
Version
1.9.7
Compatiblité
SPIP ≥ 2.0.10 et ≤ 3.2.*
État
stable
Auteur
Les Développements Durables
Licence
GPL 3
Archive
verifier-0673c-v1.9.7.zip
Taille
104.4 ko
Générée le
10-05-2020 12:53
Hébergée par
SPIP-Zone - Plugins
Compatible avec
YAML ≥ 1.5.0

Dernières modifications

  • 58883ed : fix: Deprecated in PHP 8.2-rc
  • e9ec64c : [Salvatore] [source:lang/ verifier] Export depuis https://trad.spip.net de la langue it (...)
  • 68f395f : SPIP 4 -> plus besoin de png
  • 345b567 : Revert "retour sur 16e6818, le plugin étant compatible 3.2, il doit encore fonctionner en PHP 5" (...)
  • 9731574 : une v3 spip 4++ only
  • 6adf9e0 : fix #13 : ne pas appeler normaliser sur un Array
  • 08efb49 : retour sur 16e6818, le plugin étant compatible 3.2, il doit encore fonctionner en PHP (...)
  • 5ef3e8f : Les retours de @jeanmarie sur la compat spip 4.1 sont positif, on release
  • 16e6818 : fix warning
  • 3c43858 : up de y suite aux différentes améliorations

Tickets ouverts

  • Ticket 16 : Possibilité de vérifier que 2 champs ont un contenu différent
  • Ticket 15 : Erreurs avec demande de confirmation
  • Ticket 12 : Librairies de validation
  • Ticket 9 : Verification slug et séparateurs
  • Ticket 8 : siren ou siret

Messages de forum

  • 16 septembre 2021 : Non, pas du tout, les #SAISIE ne sont associés à aucun PHP. Ça génère des champs « name=truc » en (...)
  • 15 septembre 2021 : Ah Ok du coup j’ai créé un ticket pour ics. Mais les #SAISIES sont bien associées à du php quelque (...)
  • 15 septembre 2021 : Nope, ça n’a aucun sens, puisque #SAISIE c’est juste un #INCLURE, un squelette HTML. Alors que (...)
  • 15 septembre 2021 : Coucou bonjour, Peut on faire appel à des vérifications dans les paramètres d’une #SAISIE dans un (...)
  • 20 juillet 2021 : Merci Maïeul pour ta réponse.
  • 20 juillet 2021 : Non, il n’y a pas de mecanisme pour permettre plusieurs verifications. Avec ta syntaxe là seule (...)
  • 20 juillet 2021 : Est-ce possible de faire deux vérifications successives, en utilisation auto-magique avec le (...)
  • 11 mai 2021 : corriger sur git, je releaserai ce week-end (histoire de pas releaser tous les (...)
  • 11 mai 2021 : Bonjour, J’ai encore un site en php 5.3.3 donc spip 3.1 et j’ai une erreur fatale sur le fichier (...)
  • 18 juin 2020 : Ah ok, je me disais que ça s’appliquait sur les champs à l’intérieur :) Effectivement, c’est bon (...)