Optimisation, performance, sécurité

UPDATE HEADERS

Masquer les en-têtes HTTP

Préfixe : updateheaders
Mis à jour le 6 août 2019
  • SPIP 3.0

0.2.1 - en test

Compatible : SPIP 3.0
Afficher la description

Il arrive que pour des raisons de sécurité, on ait envie ou besoin de modifier certaines en-têtes HTTP transmises par le serveur. Ce plugin a pour but de faciliter ces modifications.

Version
0.2.1
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.0.*
État
en test
Auteur
Marc Brillault
Crédits
FatCow (Logo), Gonzalo Moreno (Espagnol)
Licence
CC by-sa 4.0
Module de langue
updateheaders
Langue référence
français
Traductions
English , Español
Archive
updateheaders.zip
Taille
11.4 ko
Générée le
06-08-2019 09:21
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 1.42.11

Dernières modifications

  • Revision 116244  : svn merge -r116113:116112 . (suite de r116243 j’avais oublie d’envoyer un morceau)
  • Revision 116113  : Ne devrait pas y avoir de problème car il n’y avait pas de borne max, et comme ça, nous sommes sûr (...)
  • Revision 115072  : Ajout d’un slogan et d’une description. Ce plugin pourrait être zippé non ?
  • Revision 113106  : Je monte la version de saisie (en gardant la même branche pour réduire le risque de casse) pour (...)
  • Revision 103720  : Contrib est en https, donc j’ajoute le "s", plus divers broutilles
  • Revision 80494  : Upload du plugin v0.2.0
  • Revision 80493  : Upload du plugin v0.2.0

Messages de forum

  • 15 octobre 2017 : Sinon, si le module Headers d’Apache est activé, il suffit de mettre dans le .htaccess les lignes (...)
  • 10 février 2014 : Je parle bien de laisser le choix à l’utilisateur, on est bien d’accord sur les principes de (...)
  • 5 février 2014 : je réitère mon propos : tout ceci n’a rien à voir(mais alors ce qui s’appelle rien de rien !) avec (...)
  • 5 février 2014 : @erational, il y a effectivement un double emploi, je ne connaissais pas ce réglage. J’enlèverai (...)
  • 5 février 2014 : @g0uz : ce que tu mentionnes c’est le cas où les développeurs mettent dans les squelettes en dur (...)
  • 5 février 2014 : A noter qu’il existe aussi la constante $spip_header_silencieux qui permet de ne pas dévoiler la (...)
  • 4 février 2014 : si un spip n’est pas à jour (ni par son écran de sécurité), on aura beau masquer tout et le reste, (...)
  • 4 février 2014 : Je pense vraiment que le « problème » doit être abordé. On est tous d’accord pour dire que la (...)
  • 4 février 2014 : En fait, j’ai un peu trop centré mon intro sur cette fonctionnalité alors qu’il permet d’éditer (...)
  • 4 février 2014 : Non justement c’est bien le problème : ça n’est pas un plus en terme de sécurité. Ça ne fait que (...)
Plugins SPIP
Ce site sous SPIP 3.2.4 SVN [24325] utilise les plugins :