Outil de développement

SVP API HTTP

API REST pour interroger un serveur de plugins SVP

Préfixe : svpapi
Utilisé dans 2 sites
Mis à jour le 8 novembre 2017
  • SPIP 3.0
  • SPIP 3.1
  • SPIP 3.2

0.4.4 - en test

Compatible : SPIP 3.0 SPIP 3.1 SPIP 3.2
Afficher la description

Ce plugin est un module optionnel de SVP.
Il permet, sur un site utilisé comme un serveur de plugins à l’instar de Plugins SPIP, de fournir une API REST de récupération des données d’un plugin ou d’un paquet. Les données sont fournies, par défaut, en format JSON.

Version
0.4.4
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.2.*
État
en test
Auteur
Eric Lupinacci
Licence
GNU/GPL
Module de langue
svpapi
Langue référence
français
Traductions
français
Archive
svp_api.zip
Taille
22.7 ko
Générée le
08-11-2017 22:04
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
SVP ≥ 0.78.11
Serveur HTTP abstrait ≥ 1.2.0

Dernières modifications

  • Revision 107431  : L’API de SVP est disponible en 3.2
  • Revision 96921  : Oups un copier coller malencontreux (merci b_b)
  • Revision 96918  : Ajout de la version du plugin SVP API HTTP dans le contenu de chaque réponse.
  • Revision 96912  : Et comme prévu en appelant le nom de l’api ’format’ dans le serveur HTTP on est arrivé à mélanger (...)
  • Revision 96896  : Attention : pour suivre les recommandations de ​http://blog.octo.com/designer-une-api-rest/ on (...)
  • Revision 96895  : Correction phpdoc
  • Revision 96894  : On complète toujours le bloc d’erreur même si le status est 200. On renvoie dans ce cas un titre (...)
  • Revision 96892  : Correction du test sur le mode runtime. Simplication du code pour la gestion de l’erreur et (...)
  • Revision 96889  : Phpdoc et renommage.
  • Revision 96887  : Phpdoc. Correction de l’appel de la fonction de vérification du serveur. Ajout des items d’erreur (...)