Navigation, recherche, organisation

SPIP 400

Gestion poussée des erreurs HTTP (401, 404) pour SPIP

Préfixe : spip_400
Utilisé dans 47 sites
Mis à jour le 6 février 2020
SPIP 3.2

0.22.4 stable

Télécharger

Mis à jour le 6 février 2020

Compatible :
  • SPIP 3.0
  • SPIP 3.1
  • SPIP 3.2

Ce plugin complète la distribution de SPIP en proposant des modèles de pages d’erreur HTTP (codes 401 et 404) avec un texte explicatif et la possibilité pour l’internaute de transmettre un "ticket de bug" au webmestre du site.

Il propose notamment :

  • un message sur les pages publiques pour que l’internaute ne se perde pas ;
  • l’envoi d’un mail au webmestre avec une info complète sur l’erreur en question (utilisateur SPIP, URL, REFERER, backtrace PHP, etc) ;
  • l’écriture de messages de LOG dans un fichier spécifique ;
Fichier XML
Version
0.22.4
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.2.*
État
stable
Auteur
Piero Wbmstr
Licence
GPL 3
Copyright
2011-2012
Module de langue
Langue référence
français
Gestionnaire
salvatore
Traductions
English (Benitron, kent1) , Español (Raquel S. Bujaldón) , français , slovenčina (jaro) , Deutsch (Torsten Willmann)
Archive
spip_400-d93a7-v0.22.4.zip
Taille
32.5 ko
Générée le
06-02-2020 10:16
Hébergée par
SPIP-Zone - Plugins
Compatible avec
Zpip-dist v1 ≥ 1.0.0
Zpip-dist ≥ 2.0.5-dev

0.21.0 stable

Télécharger

Mis à jour le 24 décembre 2019

Compatible :
  • SPIP 2.0
  • SPIP 2.1

Gestion poussée des erreurs HTTP (401, 404) pour SPIP

Ce plugin tente de compléter la distribution de SPIP en proposant des modèles de pages d’erreur HTTP (codes 401 et 404) avec un texte explicatif et la possibilité pour l’internaute de transmettre un "ticket de bug" au webmestre du site.

Il propose notamment :
 un message sur les pages publiques pour que l’internaute ne se perde pas,
 l’envoi d’un mail au webmestre avec une info complète sur l’erreur en question (utilisateur SPIP, URL, REFERER, backtrace PHP, etc),
 l’écriture de messages de LOG dans un fichier spécifique ...

Une page de configuration est proposée en option si vous utilisez le plugin CFG : moteur de configuration.

Fichier XML
Version
0.21.0
Compatiblité
SPIP ≥ 2.0.0 et ≤ 2.1.*
État
stable
Auteur
Piero Wbmstr
Licence
GPL 3
Archive
spip_400-d93a7-v0.21.0.zip
Taille
20.8 ko
Générée le
24-12-2019 19:53
Hébergée par
SPIP-Zone - Plugins
Compatible avec
Zpip-dist v1 ≥ 1.0.0
CFG ≥ 1.0

Dernières modifications

Information non disponible

Messages de forum

  • 3 juin : Bonjour, J’ai installé ce plugin mais apparemment ma structure de site ne lui plaît pas car j’ai (...)
  • 23 juin 2018 : Bonjour, Y-a-t-il possibilité de personnaliser le message 401, car je voudrais renvoyer sur le (...)
  • 31 octobre 2017 : Tu peux demander un compte sur la liste spip-zone. Les mots clefs sont automatiquement ajoutés (...)
  • 31 octobre 2017 : Je veux bien mais je ne sais pas comment faire ou du moins, je ne pense pas avoir les droits (...)
  • 31 octobre 2017 : Modif apporté sur la zone. Je m’occupe également des autres plugins que tu as signalé (mais si tu (...)
  • 31 octobre 2017 : Hello Pour info, ce plugin fonctionne très bien sous SPIP 3.2 Il suffit de changer les bornes (...)
  • 10 mars 2015 : Quelque chose à mettre dans le .htaccess ?
  • 3 avril 2014 : Bonjour Merci pour ce plugin. Il marche pour les erreurs http type 404 et autres mais si un (...)
  • 12 mars 2014 : Bonsoir Hachem, Désolé, je réponds un peu tard ... en fait non, il n’y a rien d’autre à faire (...)
  • 22 décembre 2013 : il se declenche comment spip_400 ? j’essaie avec / ?page=inexistante / ?page=article&id_articl