Développement de sites et de plugins

LESS CSS

Préfixe : lesscss
Utilisé dans 504 sites
Mis à jour le 19 mai 2022
SPIP 4.1

1.5.2  en test

Télécharger

Mis à jour le 19 mai 2022

Compatible :
  • SPIP 4.1
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2

LESS est une extension de CSS ajoutant les variables, les classes, les opérations, les imbrications au langage. Facilitant ainsi l’écriture de feuilles de style complexes. http://lessphp.typesettercms.com/

Ce plugin compile à la volée tous les fichiers .less.css ou .less du squelette qui contient #INSERT_HEAD. Vous pouvez aussi forcer la compilation d’un fichier ou d’une feuille de style calculée à l’aide du filtre less_css.

Fichier XML
Version
1.5.2
Compatiblité
SPIP ≥ 3.2.0 et ≤ 4.1.*
État
en test
Auteur
Jean-Baptiste Bourgoin, Cédric Morin
Crédits
LESS.php
Licence
MIT
Module de langue
lesscss
Langue référence
français
Traductions
français
Archive
less-css-3657d-v1.5.2.zip
Taille
101.9 ko
Générée le
19-05-2022 11:16
Hébergée par
SPIP-Zone - Plugins

1.4.7  stable

Télécharger

Mis à jour le 16 novembre 2021

Compatible :
  • SPIP 4.0
  • SPIP 3.3
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

LESS est une extension de CSS ajoutant les variables, les classes, les opérations, les imbrications au langage. Facilitant ainsi l’écriture de feuilles de style complexes. http://lessphp.typesettercms.com/

Ce plugin compile à la volée tous les fichiers .less.css ou .less du squelette qui contient #INSERT_HEAD. Vous pouvez aussi forcer la compilation d’un fichier ou d’une feuille de style calculée à l’aide du filtre less_css.

Fichier XML
Version
1.4.7
Compatiblité
SPIP ≥ 3.0.0 et ≤ 4.0.*
État
stable
Auteur
Jean-Baptiste Bourgoin, Cédric Morin
Crédits
LESS.php
Licence
MIT
Archive
less-css-3657d-v1.4.7.zip
Taille
103.5 ko
Générée le
16-11-2021 14:23
Hébergée par
SPIP-Zone - Plugins

0.7.11  en test déprécié

Télécharger

Mis à jour le 2 avril 2017

Compatible :
  • SPIP 3.0
  • SPIP 2.1

LESS est une extension de CSS ajoutant les variables, les classes, les opérations, les imbrications au langage. Facilitant ainsi l’écriture de feuilles de style complexes. http://leafo.net/lessphp/

Ce plugin compile à la volée tous les fichiers .less.css ou .less du squelette qui contient #INSERT_HEAD. Vous pouvez aussi forcer la compilation d’un fichier ou d’une feuille de style calculée à l’aide du filtre less_css.

Fichier XML
Version
0.7.11
Compatiblité
SPIP ≥ 2.1.0 et ≤ 3.0.99
État
en test
Auteur
Jean-Baptiste Bourgoin
Licence
MIT
Archive
less-css-3657d-v0.7.11.zip
Taille
68.7 ko
Générée le
02-04-2017 17:55
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

  • bfd9b5c : Attention function_exists() renvoie false aussi bien en PHP 7.4 que 8.0 quand la fonction est (...)
  • b2530f9 : Fix fatale sur PHP 8+ quand ini_set est desactivée sur le serveur
  • 7819aa7 : Le plugin est compatible SPIP 4.1 aussi - la lib est testee en PHP 8.0 donc ça doit être bon (...)
  • e8cfc67 : Fix #2 : Mise a jour de la lib Less.php Depuis https://github.com/wikimedia/less.php qui semble (...)
  • 2f401bb : Eviter une erreur stats failed si jamais une des entrees est un fichier dynamique manquant (...)
  • d130dbf : Fournir une icone SVG puisqu'on est compatible SPIP 4, c'est la moindre des (...)
  • b574b6e : valide SPIP 4.0.0
  • ea0967a : ne pas utiliser la syntaxe courte pour la création des tableaux, qui n'est autorisée qu'avec les (...)
  • b969b33 : toujours indiquer au moins le fichier source less dans l'entete du css, meme si on a rien parse (...)
  • 8edec71 : Éviter une notice.

Tickets ouverts

Aucun ticket ouvert

Messages de forum

  • 26 mai 2020 : Les performances sont vraiment bien meilleures avec SCSS et le plugin ScssPhp
  • 26 mai 2020 : Bonsoir, Juste pour mémoire, voici une lib LessPHP maintenue par la fondation Wikimedia : (...)
  • 23 septembre 2019 : La version 1.4.4 fonctionne sans problème pour moi. Merci pour la réactivité ainsi que pour tout (...)
  • 22 septembre 2019 : C’est une syntaxe utilisée dans les dernières versions de PHP. J’ai corrigé sur la version 1.4.4 (...)
  • 22 septembre 2019 : La dernière mise à jour de Lesscss provoquait le message d’erreur « parse error unexpected [ in (...)
  • 8 février 2019 : Au niveau du compilateur, il nous a été conseillé de désactiver la ligne suivante : $out = (...)
  • 21 janvier 2018 : Et bien ça alors ! ça marche ! Et cela me mets bien le résultat de la compilation dans le flux (...)
  • 19 janvier 2018 : j’ai fait un essai : il est inutile de mettre la syntaxe des balises spip : manifestement, quand (...)
  • 17 janvier 2018 : Bonjour à tous J’ai créé un plugin qui se base sur SPIPr en y ajoutant des fonctionnalités qui me (...)
  • 8 octobre 2017 : J’ai trouvé : il fallait supprimer le timestamp avant de faire le filtre less : <span (...)