Images, galerie, multimédia

Javascript Scroller

Un scroller javascript de données XML

Préfixe : js_scroller
Mis à jour le 12 avril 2017
SPIP 3.2

1.44.2 stable

Télécharger

Mis à jour le 12 avril 2017

Compatible :
  • SPIP 2.0
  • SPIP 2.1
  • SPIP 3.0
  • SPIP 3.1

Javascript Scroller : un scroller javascript de données XML

Ce plugin ajoute un widget javascript sous forme de bannière défilante présentant une liste d’éléments SPIP du site.

Le widget s’appelle en utilisant la balise : #JS_SCROLLERwidth, height, type, maximum, coupe, direction, titre avec :
 width et height les dimensions (par défaut 600 x 20 pixels),
 type le type d’éléments SPIP présenté (par défaut les articles),
 maximum le nombre d’entrées présentées (par défaut 50),
 coupe le nombre de caractères du texte présenté pour chaque entrée (par défaut 40),
 direction la direction du texte (par défaut ’ltr’ : gauche->droite),
 titre le titre du bandeau (valeur par défaut selon le type - mettre ’non’ pour un titre vide).

Le code javascript du scroller est tiré de http://javascripts.vbarsan.com/.

Une documentation interne est disponible lorsque le plugin est actif sur la page publique js_scroller_documentation.

Fichier XML
Version
1.44.2
Compatiblité
SPIP ≥ 2.0.0 et ≤ 3.1.*
État
stable
Auteur
Piero Wbmstr
Licence
GPL 3
Copyright
2009-2015
Module de langue
js_scroller
Langue référence
français
Traductions
français
Archive
js_scroller-552d9-v1.44.2.zip
Taille
24.4 ko
Générée le
12-04-2017 18:02
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

Information non disponible

Messages de forum

  • 2 mars 2019 : ni celui là : http://demo-spip3.ateliers-pierrot.fr/spip.php?article8 (error 404) fonctionne (...)
  • 15 octobre 2017 : pb résolu merci.
  • 15 octobre 2017 : Bonjour, Le lien suivant ca va pas marché. http://files.spip.org/spip-zone/js_scroller.zip
  • 19 juin 2016 : Voilà ce qu’on obtient comme message dans spip.log : « JS_SCROLLER PLUGIN : lecture du xml (...)
  • 19 juin 2016 : j’ai le même problème : c’est comme si le scroller_items_xxx ne s’exécutait pas (...)
  • 10 octobre 2015 : Bonjour, Ce plugin fonctionne très bien. Merci. Mais je voudrais que, dans le cas de documents, (...)
  • 20 avril 2015 : J’ai trouvé la réponse à ma propre question Il ne faut pas utiliser id_mot=alerte mais (...)
  • 19 avril 2015 : Bonjour, Le pluging fonctionne très bien. J’ai voulu effectué un tri des articles à afficher avec (...)
  • 26 novembre 2014 : Bonjour, Une petite question : on doit entrer une largeur en pixels. Or, mon squelette est (...)
  • 14 avril 2014 : Bonjour, Peut-on avoir les x derniers articles uniquement de l’agenda ? Merci.