Édition, impression, rédaction

FCKEDITOR

Edition WYSIWYG avec FCKeditor

Préfixe : fckeditor
Utilisé dans 2472 sites
Mis à jour le 8 mai 2017
  • SPIP 1.9

1.703.0 - stable

Compatible : SPIP 1.9
Afficher la description

Caractéristiques :

  • Edition des articles, des brèves et des rubriques,
  • Propose un bouton pour passer de l’éditeur FCKEditor à l’éditeur SPIP,
  • Génère du HTML,
  • Possibilité de lier et d’insérer des fichiers et images envoyés par SPIP,
  • Suppression du découpage de texte long,
  • Coloration syntaxique du code (Geshi).

Limitations :

  • Ne pas mixer pour un même article l’édition WYSIWYG et le code SPIP,
  • Les fichiers envoyés sur le serveur par l’intermédiaire de FCKeditor sont partagés entre tous les utilisateurs,
  • Les fichiers envoyés par l’intermédiaire de FCKeditor ne sont pas utilisables par SPIP,
  • Le plugin doit être installé dans la racine du répertoire plugin de spip,
  • Le plugin n’est, à priori, pas compatible avec les plugins qui modifient les barres d’éditions (apparition de multiples boutons).

Info : De nombreux boutons peuvent être jugés inutiles (voire dangereux) par les uns ou les autres. Pour faire vos propres barre d’outils, vous pouvez retoucher le fichier fckconfig.php (dans le dossier spip_fck). Là, changez FCKConfig.ToolbarSets (BarreArticle, BarreBreve et BarreRubrique),

Version
1.703.0
Compatiblité
SPIP ≥ 1.9.2 et ≤ 1.9.2
État
stable
Auteur
Frank SAURET, Valérian
Licence
© 2007, GPL 3
Module de langue
fckeditor
Langue référence
français
Traductions
English
Archive
fckeditor_dev.zip
Taille
692.7 ko
Générée le
08-05-2017 11:04
Hébergée par
SPIP-Zone - Grenier des plugins

Dernières modifications