Outil de développement

EMOGRIFIER

Installe la librairie Emogrifier

Préfixe : emogrifier
Utilisé dans 44 sites
Mis à jour le 18 mai 2018
  • SPIP 3.2
  • SPIP 3.1
  • SPIP 3.0

1.0.11 - en test

Compatible : SPIP 3.2 SPIP 3.1 SPIP 3.0
Afficher la description

Emogrifier permet de "inliniser" du css. On lui donne du html et une feuille de style, et il insère automatiquement des styles inlines dans le html. C’est utile pour les newsletters, comme certains clients mails ne lisent pas les feuilles de style mais acceptent les styles inline.

Version
1.0.11
Compatiblité
SPIP ≥ 3.0.5 et ≤ 3.2.*
État
en test
Auteur
Vertige ASBL
Licence
GNU/GPL
Module de langue
emogrifier
Langue référence
français
Traductions
français
Archive
emogrifier.zip
Taille
40.5 ko
Générée le
18-05-2018 15:04
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
php ≥ 5.5

Dernières modifications

  • Revision 110302  : maj de la lib emogrifier en 2.0.0 pas mal de changement de structure du code , refactoring des (...)
  • Revision 108164  : on prends en compte l’équivalent en squelette spip du fichier css définie pour la inlinisation si (...)
  • Revision 107511  : La lib emogrifier n’est compatible que php 5.5 minimum on le précise dans le paquet, pour (...)
  • Revision 106841  : compatible 3.2
  • Revision 106578  : oups…
  • Revision 106577  : ajout de _EMOGRIFIER_DISABLE_STYLE_BLOCK_PARSING = true par defaut comme le filtre emogrifier (...)
  • Revision 106565  : si _EMOGRIFIER_CSS n’est pas défini, c’est cette feuille qui est chargée, autant qu’elle existe (...)
  • Revision 106563  : mise a jour de la lib emogrifier
  • Revision 105537  : Up de Z
  • Revision 105536  : Pouvoir spécifier plusieurs fichier css dans la constante avec un séparateur (...)