Optimisation, performance, sécurité

Content Security Policy

Préfixe : csp
Utilisé dans 2 sites
Mis à jour le 3 octobre 2015
SPIP 3.2

0.3.0 en développement

Télécharger

Mis à jour le 3 octobre 2015

Compatible :
  • SPIP 3.0

Permet d’activer le mécanisme de sécurité Content Security Policy qui permet de restreindre l’origine du contenu des pages (images, styles et surtout scripts). Ce mécanisme permet de se prémunir contre les éventuelles failles XSS (« Cross-site scripting »).

Fichier XML
Version
0.3.0
Compatiblité
SPIP ≥ 3.0.14 et ≤ 3.0.*
État
en développement
Auteur
Olivier Tétard
Licence
GNU/GPL v3
Archive
spip_csp-31e04-versions_0.3.0.zip
Taille
190.1 ko
Générée le
03-10-2015 12:59
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 1.24.0
Nécessite les librairies
select2

0.2.0 en développement

Télécharger

Mis à jour le 28 janvier 2014

Compatible :
  • SPIP 3.0

Permet d’activer le mécanisme de sécurité Content Security Policy qui permet de restreindre l’origine du contenu des pages (images, styles et surtout scripts). Ce mécanisme permet de se prémunir contre les éventuelles failles XSS (« Cross-site scripting »).

Fichier XML
Version
0.2.0
Compatiblité
SPIP ≥ 3.0.14 et ≤ 3.0.*
État
en développement
Auteur
Olivier Tétard
Licence
GNU/GPL v3
Archive
spip_csp-31e04-versions_0.2.0.zip
Taille
188.3 ko
Générée le
28-01-2014 21:14
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 1.24.0
Nécessite les librairies
select2

0.1.0 en développement

Télécharger

Mis à jour le 23 janvier 2014

Compatible :
  • SPIP 3.0

Permet d’activer le mécanisme de sécurité Content Security Policy qui permet de restreindre l’origine du contenu des pages (images, styles et surtout scripts). Ce mécanisme permet de se prémunir contre les éventuelles failles XSS (« Cross-site scripting »).

Fichier XML
Version
0.1.0
Compatiblité
SPIP ≥ 3.0.14 et ≤ 3.0.*
État
en développement
Auteur
Olivier Tétard
Licence
GNU/GPL v3
Module de langue
csp
Langue référence
français
Traductions
français
Module de langue
csp_rapport
Langue référence
français
Traductions
français
Archive
spip_csp-31e04-versions_0.1.0.zip
Taille
186.6 ko
Générée le
23-01-2014 10:59
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Saisies pour formulaires ≥ 1.24.0
Nécessite les librairies
select2

Dernières modifications

  • df6af6a : Version 0.3.0
  • d03da80 : Nettoyage
  • 0ebd76a : Option avancée : possibilité d’utiliser des 'nonce' pour les scripts en ligne (CSP 1.1) Cette (...)
  • b0bb31a : Option avancée : possibilité d'utiliser la balise (CSP 1.1) Cette option permet d’intégrer la (...)
  • 60445be : Modification de la liste des domaines suggérés dans le formulaire de configuration.
  • 860d59a : Formulaire de configuration : ajout d’un message d’avertissement en cas de surcharge. Lors de la (...)
  • 95b14de : Déplacement du code CSS du formulaire de configuration dans le fichier style_prive_plugin_csp.html
  • d699057 : Déplacement du code JS dans javascript/csp_formulaire_configurer_csp.js
  • 60ab06c : Nettoyage
  • 63742ef : Amélioration de la prise en charge des options 'unsafe-eval' et 'unsafe-inline'. Dans l’interface (...)