Édition, impression, rédaction

CORRECTION DES LIENS INTERNES

Liens internes : soyez beaux !

Préfixe : correction_liens_internes
Utilisé dans 168 sites
Mis à jour le 7 février 2018
  • SPIP 3.0
  • SPIP 3.1
  • SPIP 3.2

1.4.2 - stable

Compatible : SPIP 3.0 SPIP 3.1 SPIP 3.2
Afficher la description

Corrige automatiquement les liens internes insérés par copier-coller de l’url. [texte->http://www.example.com/spip.php?article1], inséré dans le site example.com devient [texte->article1].

Version
1.4.2
Compatiblité
SPIP ≥ 3.0.0 et ≤ 3.2.*
État
stable
Auteur
Maïeul Rouquette, Nicolas Dorigny
Crédits
Dmitry Mirolyubov sous Licence Creative Commons - Attribution
Licence
GPL 3
Archive
correction_liens_internes.zip
Taille
6 ko
Générée le
07-02-2018 15:04
Hébergée par
SPIP-Zone - Plugins
Compatible avec
Multidomaines ≥ 2.0.0

Dernières modifications

  • Revision 108840  : Version 1.4.2 Gérer correctement les ancres sur les urls publiques
  • Revision 106289  : Avec les logs en moins, c’est mieux
  • Revision 106281  : traiter les documents en urls absolus aussi Version 1.4.0
  • Revision 106280  : En cas d’utilisation de CORRECTION_LIENS_INTERNES_AUTRES_DOMAINES avec plusieurs domaines (...)
  • Revision 106099  : Eviter un warning
  • Revision 103710  : des tabs à la place d’espace pour être un peu plus conforme avec ​http://www.spip.net/fr_article3497.htm
  • Revision 103703  : compatible 3.2 + deux warnings PHP
  • Revision 87575  : tout cela mérite bien un changement de y
  • Revision 87574  : et maintenant, corriger dans le cas où on a copié une url du privé
  • Revision 87573  : pour préparer l’application de la correction des liens internes à ceux copiés-collés depuis le (...)

Messages de forum

  • 14 décembre : Bonjour, merci de votre réponse. Merci j’avais testé et ai retesté ce matin : négatif (voir copie (...)
  • 14 décembre : Bonjour, Voici les plugins qui figurent sur le site défaillant : Coche Mots 1.2.1 - stable (...)
  • 14 décembre : Bonjour, Oui, je confirme le plugin est compatible SPIP 3.2. C’est marqué sur sa fiche : (...)
  • 13 décembre : Alors pour la compat 3.2 ça je peux répondre : c’est compatible ! Pour le reste je laisse Teddy (...)
  • 13 décembre : effectivement il y avait des problèmes en cas d’image. La nouvelle version du plugin pour php 7 (...)
  • 13 décembre : bonsoir,merci pour ce plugin. j’aimerai savoir s’il est compatible avec 3.2 et si vous avez eu (...)
  • 13 décembre : Ça serait un avantage d’avoir de vrais tags de version en Git…
  • 13 décembre : Dans les champs d’une ligne, c’est comme les titres dans les contenus SPIP, c’est pas prévu de (...)
  • 13 décembre : tu cliques sur « Mettre à jour » et hop… Oups. Une erreur inattendue a empêché de soumettre le (...)
  • 13 décembre : c’est à dire ? que se passe-t-il exactement ?