Édition, impression, rédaction

Accès Restreint Partiel

Restreindre un peu mais pas tout

Préfixe : arp
Utilisé dans 9 sites
Mis à jour le 22 janvier 2018
SPIP 3.2

1.1.0 en développement

Télécharger

Mis à jour le 22 janvier 2018

Compatible :
  • SPIP 3.0
  • SPIP 3.1

Ce plugin vient en supplément du plugin Accès Restreint. Ce dernier permet d’empêcher les accès aux rubriques/articles appartenant à une zone définie comme étant à accès restreint. Les rubriques/articles sont alors totalement invisibles aux visiteurs n’ayant pas les droits d’accès.

ARP autorise l’accès ; les rubriques/articles sortent dans les résultats des boucles. Mais le contenu des #TEXTE est filtré de telle sorte de ne laisser voir qu’une partie.

 Le rédacteur peut choisir l\endroit précis de la coupe du texte, en ajoutant un tag dans le texte à l’emplacement désiré.
 On peut choisir la règle de filtrage à appliquer en attribuant un mot-clé à l’article : arp_regle_1, arp_regle_(N) Les règles étant définies dans la configuration de l’article.
 Enfin, si aucune des possibilités ci-dessus n’est utilisée, la règle de filtrage par défaut est appliquée. Elle est définie dans la conf. du plugin.

Il est possible d’ajouter du texte avant et après le texte filtré, par exemple pour renvoyer le visiteur vers une page d’abonnement.

Le plugin met à disposition quelques modèles, à insérer par exemple dans le texte avant ou après.
  pour lister les documents présents dans l’article,
  pour listes les intertitres.

Fichier XML
Version
1.1.0
Compatiblité
SPIP ≥ 3.0.9 et ≤ 3.1.*
État
en développement
Auteur
Bruno Caillard
Licence
GNU/GPL
Module de langue
arp
Langue référence
français
Traductions
français
Archive
acces_restreint_partiel-e741b-v1.1.0.zip
Taille
29.1 ko
Générée le
22-01-2018 12:54
Hébergée par
SPIP-Zone - Plugins
Nécessite les plugins
Accès Restreint ≥ 3.3.1

Dernières modifications

Information non disponible

Messages de forum

  • 6 décembre 2019 : Il suffit de télécharger le zip du plugin, le décompresser et aller dans la branche la plus (...)
  • 6 décembre 2019 : J’ailerais bien le tester, mais impossible d’ajouter un plugin qui n’est pas 2.2 compatible. (...)
  • 6 décembre 2019 : Je veux bien le tester, mais je ne peux pas l’installer. Spip refuse. Comment fait-on (...)
  • 6 décembre 2019 : Tu l’as testé sur une 3.2 et ça fonctionne ?
  • 5 décembre 2019 : Bonjour meci pour ce plugin. Pouvez-vous le marquer 3.2 compatible svp. Merci
  • 13 avril 2019 : Bonjour Avez-vous essayé avec un autre filtre que arp_filtre_rien ?
  • 4 avril 2019 : Je voudrais laisser aux rédacteur d’une rubrique le choix de filtrer, ou non, leurs articles. (...)
  • 20 octobre 2017 : En mettant 3.0.9 ;3.1.* le plugin ne peut toujours pas être activé dans le gestionnaire des (...)
  • 20 octobre 2017 : Merci Pierre pour votre réponse rapide. En mettant : 3.0.9 ;3.1.* le plugin est toujours (...)
  • 20 octobre 2017 : En mettant [3.0.9 ;3.1.*[ cela donne quoi ?