Outil de développement

SVN UPDATE

Pouvoir faire une mise à jour SVN du site

Préfixe : svn_update
Utilisé dans 27 sites
Mis à jour le 2 avril 2017
  • SPIP 2.1
  • SPIP 2.0
  • SPIP 1.9

0.33.0 - en développement

Compatible : SPIP 2.1 SPIP 2.0 SPIP 1.9
Afficher la description

Un utilisateur (par defaut, l’administrateur numero 1) est autorisé à faire une mise à jour SVN du site ou de tout autre répertoire. Pour cela il doit se rendre sur la page ecrire/?exec=svn_update et sélectionner les éléments à mettre à jour.

Seuls les administrateurs déclarés commes webmestres (constante _ID_WEBMESTRES) sont autorisé à gérér la configuration du plugin.

La configuration se fait dans le gestionnaire cfg :

  • pour définir la liste des administrateurs autorisés à procéder aux mises à jour (par défaut seul l’administrater d’id 1 est autorisé).
  • pour déclarer la liste des répertoires concernés, en donnant pour chacun une ligne : source destination [revision] [user]
    Par exemple :
    svn://zone.spip.org/spip-zone/_squelettes_/sedna squelettes/sedna
    svn://zone.spip.org/spip-zone/_plugins_/_stable_/cfg plugins/cfg
Version
0.33.0
Compatiblité
1.9.0 ≤ SPIP ≤ 2.1.*
État
en développement
Auteur
Cedric, Fil
Licence
GPL 3
Archive
svn_update.zip
Taille
15 ko
Générée le
02-04-2017 18:05
Hébergée par
SPIP-Zone - Plugins

Dernières modifications

  • Revision 103720  : Contrib est en https, donc j’ajoute le "s", plus divers broutilles
  • Revision 84614  : spip-contrib.net -> contrib.spip.net pour Francky find . -name ’*’ | grep ’/lang/’ | xargs sed -i (...)
  • Revision 57140  : refaire marchouiller svn update (le cfg est totalement pete)
  • Revision 52679  : Slogan, Borne sup spip mise à 2.0.99 au vu du journal svn. A confirmer, Cédric, fil ? (Si oui, (...)
  • Revision 34499  : Premier jet de la categorie outil
  • Revision 32375  : debug
  • Revision 28930  : on bouge
  • Revision 28279  : ergonomie : faire marcher la selection des auteurs designes en 1.9.x, et nombre de ligne du (...)

Messages de forum

  • 16 septembre 2011 : ecrire/?exec=cfg&cfg=svn_update provoque 4 erreurs de squellette : Double occurrence de (...)
  • 20 juin 2009 : Bonjour, Ce plugins me parait très intéressant car il permettrait à des WebMaster de mettre à (...)
  • 28 janvier 2009 : tu connais la réponse : gogogo
  • 28 janvier 2009 : est que ça serait mieux de ajouter un « 2>&1 » a le command a passer a exec() pour afficher (...)